Edge Rails no Windows Vista

Uma das mudanças do Rails 2.2 é não inclusão do bundle do MySQL, responsável por conectar seu projeto ao banco. Mês passado eu postei sobre isso e hoje, ao tentar instalar o gem do MySQL no Windows Vista de um co-worker, me deparei com um problema na DLL libmySQL.dll.

A solução encontrada foi copiar esse arquivo (geralmente em C:\Program Files\MySQL\MySQL Server 4.1\bin\) para a pasta bin do Ruby (por exemplo: C:\ruby\bin).

Que fique documentado ;)

 

Leonardo

Registros de Leonardo Faria sobre desenvolvimento web

 
  • Leandro

    Estou com um problema no meu Windows XP. Crio o projeto no rails mas quando vou rodar o migrate está ocorrendo o seguinte erro: !!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
    rake aborted!

    O que devo fazer? socorrroooooooooooooo!!!!